is this a bug or my mistake?

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

is this a bug or my mistake?

speedinghong
when i import a global SST product image,the geo information seems wrong with longitude,it shows like this
W179/59  W179/59/30  E180  E179/59/30  E179/59

in my header file,gcps are like this,and it's ok when shown in envi.

geo points = {1.5,1.5,89.98,-179.982,8192.500000,1.5,89.98,179.982,1.5,4096.500000,-89.98,-179.982,8192.500000,4096.500000,-89.98,179.982}
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

Trevor Clarke
We don't natively support this format so I suspect that the GDAL importer is loading this data. Grab a copy of the GDAL command line tools and run a gdalinfo on the file. See if it returns the same geo coordinates as Opticks. If not, can you point me to a sample SST file and and I'll take a look.


On Fri, Nov 23, 2012 at 9:27 AM, speedinghong <[hidden email]> wrote:
when i import a global SST product image,the geo information seems wrong with
longitude,it shows like this
W179/59  W179/59/30  E180  E179/59/30  E179/59

in my header file,gcps are like this,and it's ok when shown in envi.

geo points =
{1.5,1.5,89.98,-179.982,<a href="tel:8192.500000" value="+18192500000">8192.500000,1.5,89.98,179.982,1.5,4096.500000,-89.98,-179.982,8192.500000,4096.500000,-89.98,179.982}




--
View this message in context: http://opticks-devs.2021163.n4.nabble.com/is-this-a-bug-or-my-mistake-tp4652878.html
Sent from the opticks-devs mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs



--
Trevor R.H. Clarke
Computer Science House
Rochester Institute of Technology
[hidden email]
http://www.csh.rit.edu/~retrev/


------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

speedinghong
In reply to this post by speedinghong
the format is in envi standard type .hdr



----------
邮件发自微信

------------------ 原始邮件 ------------------
发送时间: 2012年11月23日(星期五) 23:46
收件人: "opticks-devs" <[hidden email]>;
主题: Re: [Opticks-devs] is this a bug or my mistake?


We don't natively support this format so I suspect that the GDAL importer is loading this data. Grab a copy of the GDAL command line tools and run a gdalinfo on the file. See if it returns the same geo coordinates as Opticks. If not, can you point me to a sample SST file and and I'll take a look.


On Fri, Nov 23, 2012 at 9:27 AM, speedinghong <[hidden email]> wrote:
when i import a global SST product image,the geo information seems wrong with
longitude,it shows like this
W179/59 ��W179/59/30 ��E180 ��E179/59/30 ��E179/59

in my header file,gcps are like this,and it's ok when shown in envi.

geo points =
{1.5,1.5,89.98,-179.982,<a href="tel:8192.500000" value="+18192500000">8192.500000,1.5,89.98,179.982,1.5,4096.500000,-89.98,-179.982,8192.500000,4096.500000,-89.98,179.982}




--
View this message in context: http://opticks-devs.2021163.n4.nabble.com/is-this-a-bug-or-my-mistake-tp4652878.html
Sent from the opticks-devs mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs



--
Trevor R.H. Clarke
Computer Science House
Rochester Institute of Technology
[hidden email]
http://www.csh.rit.edu/~retrev/


------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

speedinghong
In reply to this post by speedinghong
i'll try it tomorrow,if not,i'll show you the image data,for it's midnight here


------------------ Original ------------------
From:  "Trevor Clarke"<[hidden email]>;
Date:  Fri, Nov 23, 2012 11:46 PM
To:  "opticks-devs"<[hidden email]>;
Subject:  Re: [Opticks-devs] is this a bug or my mistake?

We don't natively support this format so I suspect that the GDAL importer is loading this data. Grab a copy of the GDAL command line tools and run a gdalinfo on the file. See if it returns the same geo coordinates as Opticks. If not, can you point me to a sample SST file and and I'll take a look.


On Fri, Nov 23, 2012 at 9:27 AM, speedinghong <[hidden email]> wrote:
when i import a global SST product image,the geo information seems wrong with
longitude,it shows like this
W179/59 W179/59/30 E180 E179/59/30 E179/59

in my header file,gcps are like this,and it's ok when shown in envi.

geo points =
{1.5,1.5,89.98,-179.982,8192.500000,1.5,89.98,179.982,1.5,4096.500000,-89.98,-179.982,8192.500000,4096.500000,-89.98,179.982}




--
View this message in context: http://opticks-devs.2021163.n4.nabble.com/is-this-a-bug-or-my-mistake-tp4652878.html
Sent from the opticks-devs mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs



--
Trevor R.H. Clarke
Computer Science House
Rochester Institute of Technology
[hidden email]
http://www.csh.rit.edu/~retrev/


------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

Trevor Clarke
In reply to this post by speedinghong

I'll take a look and see if I can recreate the issue

On Nov 23, 2012 10:51 AM, "speedinghong" <[hidden email]> wrote:
the format is in envi standard type .hdr



----------
邮件发自微信

------------------ 原始邮件 ------------------
发件人: "Trevor Clarke" <[hidden email]>;
发送时间: 2012年11月23日(星期五) 23:46
收件人: "opticks-devs" <[hidden email]>;
主题: Re: [Opticks-devs] is this a bug or my mistake?


We don't natively support this format so I suspect that the GDAL importer is loading this data. Grab a copy of the GDAL command line tools and run a gdalinfo on the file. See if it returns the same geo coordinates as Opticks. If not, can you point me to a sample SST file and and I'll take a look.


On Fri, Nov 23, 2012 at 9:27 AM, speedinghong <[hidden email]> wrote:
when i import a global SST product image,the geo information seems wrong with
longitude,it shows like this
W179/59 ��W179/59/30 ��E180 ��E179/59/30 ��E179/59

in my header file,gcps are like this,and it's ok when shown in envi.

geo points =
{1.5,1.5,89.98,-179.982,<a href="tel:8192.500000" value="+18192500000" target="_blank">8192.500000,1.5,89.98,179.982,1.5,<a href="tel:4096.500000" value="+14096500000" target="_blank">4096.500000,-89.98,-179.982,<a href="tel:8192.500000" value="+18192500000" target="_blank">8192.500000,<a href="tel:4096.500000" value="+14096500000" target="_blank">4096.500000,-89.98,179.982}




--
View this message in context: http://opticks-devs.2021163.n4.nabble.com/is-this-a-bug-or-my-mistake-tp4652878.html
Sent from the opticks-devs mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs



--
Trevor R.H. Clarke
Computer Science House
Rochester Institute of Technology
[hidden email]
http://www.csh.rit.edu/~retrev/


------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs


------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

speedinghong
i tried that with someting gdalinfor.exe,didn't get anything just the corner coordinates in pixel postions.It seems the email box doesn't allow me to post the data.and when i change the corner longitude range between -179 and -79,it looks right.if between -179 and 79,its result meet the similar same problem.i think you can recreate the issue with any envi .hdr type data whose gcp coordinates changed with mine
geo points = {1.5,1.5,89.98,-179.982,8192.500000,1.5,89.98,179.982,1.5,4096.500000,-89.98,-179.982,8192.500000,4096.500000,-89.98,179.982}
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

speedinghong
In reply to this post by Trevor Clarke
and of course the col/row nums should be changed according to the data you use.
in my further test,i kind of  conclude that the longitude cannot expand 180 degrees,if the longitude range is within 180d,the result is ok.if greater than 180degrees,it will understand -130lon 60lon as W130 W180 E60,but it should be W130 W0 E60
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

speedinghong
In reply to this post by Trevor Clarke
Reply | Threaded
Open this post in threaded view
|

Re: is this a bug or my mistake?

speedinghong
In reply to this post by Trevor Clarke
i have fixed my problem.
i have checked the code in HdrGeoreference::execute,it has something like
 // A value of more than 180.0 in maxLonSeparation indicates a special condition
if (maxLonSeparation > 180.0)  
   {
      for (i = 0; i < pGcpList->getSelectedPoints().size(); ++i)
      {
         if (latlonValues[i].mY < 0.0)
         {
            latlonValues[i].mY = 360.0 + latlonValues[i].mY;//remove this line
         }
      }
   }
it means if the longitude range is greater than 180,the longitude in the west(<0) will add 360degrees.
in that case -130d 60d will be taken as 230d 60d,then fit reslut will be 230d 180d 60d,that is -130d -180d 60d.so i just remove the line in which add 360degrees above.if anything is wrong in my understanding,please tell me,thanks