Which version of QT Creator is supported?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Which version of QT Creator is supported?

Hotka, Michael

Hello…

 

What version of QT Creator is supported by Opticks 4.11.0?

 

When I compile using QT Creator 5.3.2, I get a MOC compatibility error. Someone on my team suggested using an older version of QT Creator and I am wondering which one?

 

Thanks

 

Mike



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Which version of QT Creator is supported?

tclarke
Administrator

We don’t support compilation on creator (though  you can probably set it up to work). If you’re referring to the qt toolkit (which is part of the creator package) than you need to use the build that’s included with the opticks sdk.

 

See http://opticks.org/docs/sdk/latest-stable/plugintutorial_building.html  for information on downloading the dependency binaries. If you’re using Linux, follow the Solaris instructions.

----------------------

Trevor R.H. Clarke

Software Engineer, Ball Aerospace

(937)320-7087

 

From: Hotka, Michael [mailto:[hidden email]]
Sent: Friday, November 14, 2014 12:42 PM
To: [hidden email]
Subject: [Opticks-devs] Which version of QT Creator is supported?

 

Hello…

 

What version of QT Creator is supported by Opticks 4.11.0?

 

When I compile using QT Creator 5.3.2, I get a MOC compatibility error. Someone on my team suggested using an older version of QT Creator and I am wondering which one?

 

Thanks

 

Mike



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Which version of QT Creator is supported?

Dustan Adkins
I don't have a 4.11.0 dependencies directory handy, but you should be able to find the binaries in the Dependencies/64/bin directory (or 32 if you want to build 32-bit). Good luck!

On Nov 14, 2014, at 12:53 PM, Clarke, Trevor <[hidden email]> wrote:

We don’t support compilation on creator (though  you can probably set it up to work). If you’re referring to the qt toolkit (which is part of the creator package) than you need to use the build that’s included with the opticks sdk.

 

See http://opticks.org/docs/sdk/latest-stable/plugintutorial_building.html  for information on downloading the dependency binaries. If you’re using Linux, follow the Solaris instructions.

----------------------

Trevor R.H. Clarke

Software Engineer, Ball Aerospace

(937)320-7087

 

From: Hotka, Michael [[hidden email]]
Sent: Friday, November 14, 2014 12:42 PM
To: [hidden email]
Subject: [Opticks-devs] Which version of QT Creator is supported?

 

Hello…

 

What version of QT Creator is supported by Opticks 4.11.0?

 

When I compile using QT Creator 5.3.2, I get a MOC compatibility error. Someone on my team suggested using an older version of QT Creator and I am wondering which one?

 

Thanks

 

Mike



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.
------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Which version of QT Creator is supported?

John Tobe

For anyone wondering, Opticks 4.11.0 and 4.12.0 are both compiled against QT 4.7.1.  So maybe if you install the corresponding version of QT creator it will work?

 

From: Dustan Adkins [mailto:[hidden email]]
Sent: Friday, November 14, 2014 2:58 PM
To: [hidden email]
Subject: Re: [Opticks-devs] Which version of QT Creator is supported?

 

I don't have a 4.11.0 dependencies directory handy, but you should be able to find the binaries in the Dependencies/64/bin directory (or 32 if you want to build 32-bit). Good luck!


On Nov 14, 2014, at 12:53 PM, Clarke, Trevor <[hidden email]> wrote:

We don’t support compilation on creator (though  you can probably set it up to work). If you’re referring to the qt toolkit (which is part of the creator package) than you need to use the build that’s included with the opticks sdk.

 

See http://opticks.org/docs/sdk/latest-stable/plugintutorial_building.html  for information on downloading the dependency binaries. If you’re using Linux, follow the Solaris instructions.

----------------------

Trevor R.H. Clarke

Software Engineer, Ball Aerospace

(937)320-7087

 

From: Hotka, Michael [[hidden email]]
Sent: Friday, November 14, 2014 12:42 PM
To: [hidden email]
Subject: [Opticks-devs] Which version of QT Creator is supported?

 

Hello…

 

What version of QT Creator is supported by Opticks 4.11.0?

 

When I compile using QT Creator 5.3.2, I get a MOC compatibility error. Someone on my team suggested using an older version of QT Creator and I am wondering which one?

 

Thanks

 

Mike



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk

_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs



This message and any enclosures are intended only for the addressee. Please
notify the sender by email if you are not the intended recipient. If you are
not the intended recipient, you may not use, copy, disclose, or distribute this
message or its contents or enclosures to any other person and any such actions
may be unlawful. Ball reserves the right to monitor and review all messages
and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=157005751&iu=/4140/ostg.clktrk
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Loading...