OBIA Plugin Issues

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

OBIA Plugin Issues

ganesh@nic.in
Dear Sir,
I have downloaded the OBIA plugin and installed in my Opticks as installe(4.9.1).After executing the Image Segmentation I am getting errors like
MeanShift.exe has stopped working  a problem caused the progarmmee to work properly.CBIA plaun is woring fine new code with
with regards
Ganesh
9650807966




Ganesh Khadanga, Technical Director
LRISD NIC HQRS, A-BLOCK
5th Floor, CGO COMPLEX, LODI ROAD
New Delhi-110003
email: [hidden email]
------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: OBIA Plugin Issues

tclarke
Administrator

The OBIA extension is not an officially supported extension (it was made by a GSoC student but hasn’t been integrated with Opticks) so I don’t know too much about the internals. Unfortunately, the student didn’t have time to generate an AEB installer which would tell us what version of Opticks he built against. I suspect the binary you are using was not build with 4.9.1. (I believe he mentioned in one of his reports or on the mailing list which version but I don’t recall offhand).

 

I’ve tried to build it against Opticks 4.9.1 (windows 32-bit). I haven’t really tested it so let me know if this works. You’ll find the build here: https://dl.dropbox.com/u/139546/OBIA.zip

 

From: Ganesh [mailto:[hidden email]]
Sent: Sunday, March 17, 2013 2:22 PM
To: [hidden email]
Subject: [Opticks-devs] OBIA Plugin Issues

 

Dear Sir,
I have downloaded the OBIA plugin and installed in my Opticks as installe(4.9.1).After executing the Image Segmentation I am getting errors like
MeanShift.exe has stopped working  a problem caused the progarmmee to work properly.CBIA plaun is woring fine new code with
with regards
Ganesh
9650807966




Ganesh Khadanga, Technical Director
LRISD NIC HQRS, A-BLOCK
5th Floor, CGO COMPLEX, LODI ROAD
New Delhi-110003
email: [hidden email]


This message and any enclosures are intended only for the addressee.  Please 

notify the sender by email if you are not the intended recipient.  If you are 

not the intended recipient, you may not use, copy, disclose, or distribute this 

message or its contents or enclosures to any other person and any such actions 

may be unlawful.  Ball reserves the right to monitor and review all messages 

and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: OBIA Plugin Issues

mohit kumar
Hi Ganesh,
I had build the pluggin with Opticks 4.9.0. Did you select the data directory and all the three parameters Spatial bandwidth, Range bandwidth and minimum region area? Do let me know if the error is not solved.
Thanks tclarke for the help regarding the build issue. If you want I will generate an AEB installer for the pluggin.

Regards,,


On Mon, Mar 18, 2013 at 4:16 AM, Clarke, Trevor <[hidden email]> wrote:

The OBIA extension is not an officially supported extension (it was made by a GSoC student but hasn’t been integrated with Opticks) so I don’t know too much about the internals. Unfortunately, the student didn’t have time to generate an AEB installer which would tell us what version of Opticks he built against. I suspect the binary you are using was not build with 4.9.1. (I believe he mentioned in one of his reports or on the mailing list which version but I don’t recall offhand).

 

I’ve tried to build it against Opticks 4.9.1 (windows 32-bit). I haven’t really tested it so let me know if this works. You’ll find the build here: https://dl.dropbox.com/u/139546/OBIA.zip

 

From: Ganesh [mailto:[hidden email]]
Sent: Sunday, March 17, 2013 2:22 PM
To: [hidden email]
Subject: [Opticks-devs] OBIA Plugin Issues

 

Dear Sir,
I have downloaded the OBIA plugin and installed in my Opticks as installe(4.9.1).After executing the Image Segmentation I am getting errors like
MeanShift.exe has stopped working  a problem caused the progarmmee to work properly.CBIA plaun is woring fine new code with
with regards
Ganesh
9650807966




Ganesh Khadanga, Technical Director
LRISD NIC HQRS, A-BLOCK
5th Floor, CGO COMPLEX, LODI ROAD
New Delhi-110003
email: [hidden email]

This message and any enclosures are intended only for the addressee.  Please 

notify the sender by email if you are not the intended recipient.  If you are 

not the intended recipient, you may not use, copy, disclose, or distribute this 

message or its contents or enclosures to any other person and any such actions 

may be unlawful.  Ball reserves the right to monitor and review all messages 

and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs




--
Mohit Kumar
+91-970-3840-175
Lab For Spatial Informatics
International Institute of Information Technology
Hyderabad, India

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: OBIA Plugin Issues

tclarke
Administrator

An AEB would be great. There are instructions in the SDK docs or you can use one of the official extensions as a template (spectral is a good example).

 

http://opticks.org/docs/sdk/latest-stable/howto_writeinstaller.html

 

From: mohit kumar [mailto:[hidden email]]
Sent: Sunday, March 17, 2013 10:25 PM
To: [hidden email]
Subject: Re: [Opticks-devs] OBIA Plugin Issues

 

Hi Ganesh,

I had build the pluggin with Opticks 4.9.0. Did you select the data directory and all the three parameters Spatial bandwidth, Range bandwidth and minimum region area? Do let me know if the error is not solved.

Thanks tclarke for the help regarding the build issue. If you want I will generate an AEB installer for the pluggin.

Regards,,

 

On Mon, Mar 18, 2013 at 4:16 AM, Clarke, Trevor <[hidden email]> wrote:

The OBIA extension is not an officially supported extension (it was made by a GSoC student but hasn’t been integrated with Opticks) so I don’t know too much about the internals. Unfortunately, the student didn’t have time to generate an AEB installer which would tell us what version of Opticks he built against. I suspect the binary you are using was not build with 4.9.1. (I believe he mentioned in one of his reports or on the mailing list which version but I don’t recall offhand).

 

I’ve tried to build it against Opticks 4.9.1 (windows 32-bit). I haven’t really tested it so let me know if this works. You’ll find the build here: https://dl.dropbox.com/u/139546/OBIA.zip

 

From: Ganesh [mailto:[hidden email]]
Sent: Sunday, March 17, 2013 2:22 PM
To: [hidden email]
Subject: [Opticks-devs] OBIA Plugin Issues

 

Dear Sir,
I have downloaded the OBIA plugin and installed in my Opticks as installe(4.9.1).After executing the Image Segmentation I am getting errors like
MeanShift.exe has stopped working  a problem caused the progarmmee to work properly.CBIA plaun is woring fine new code with
with regards
Ganesh
9650807966




Ganesh Khadanga, Technical Director
LRISD NIC HQRS, A-BLOCK
5th Floor, CGO COMPLEX, LODI ROAD
New Delhi-110003
email: [hidden email]

This message and any enclosures are intended only for the addressee.  Please 
 
notify the sender by email if you are not the intended recipient.  If you are 
 
not the intended recipient, you may not use, copy, disclose, or distribute this 
 
message or its contents or enclosures to any other person and any such actions 
 
may be unlawful.  Ball reserves the right to monitor and review all messages 
 
and enclosures sent to or from this email address.


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs




--

Mohit Kumar

+91-970-3840-175

Lab For Spatial Informatics
International Institute of Information Technology
Hyderabad, India


This message and any enclosures are intended only for the addressee.  Please 

notify the sender by email if you are not the intended recipient.  If you are 

not the intended recipient, you may not use, copy, disclose, or distribute this 

message or its contents or enclosures to any other person and any such actions 

may be unlawful.  Ball reserves the right to monitor and review all messages 

and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: OBIA Plugin Issues

mohit kumar
Thanks tclarke, will write it in a few days.

Regards,



On Mon, Mar 18, 2013 at 7:03 PM, Clarke, Trevor <[hidden email]> wrote:

An AEB would be great. There are instructions in the SDK docs or you can use one of the official extensions as a template (spectral is a good example).

 

http://opticks.org/docs/sdk/latest-stable/howto_writeinstaller.html

 

From: mohit kumar [mailto:[hidden email]]
Sent: Sunday, March 17, 2013 10:25 PM
To: [hidden email]
Subject: Re: [Opticks-devs] OBIA Plugin Issues

 

Hi Ganesh,

I had build the pluggin with Opticks 4.9.0. Did you select the data directory and all the three parameters Spatial bandwidth, Range bandwidth and minimum region area? Do let me know if the error is not solved.

Thanks tclarke for the help regarding the build issue. If you want I will generate an AEB installer for the pluggin.

Regards,,

 

On Mon, Mar 18, 2013 at 4:16 AM, Clarke, Trevor <[hidden email]> wrote:

The OBIA extension is not an officially supported extension (it was made by a GSoC student but hasn’t been integrated with Opticks) so I don’t know too much about the internals. Unfortunately, the student didn’t have time to generate an AEB installer which would tell us what version of Opticks he built against. I suspect the binary you are using was not build with 4.9.1. (I believe he mentioned in one of his reports or on the mailing list which version but I don’t recall offhand).

 

I’ve tried to build it against Opticks 4.9.1 (windows 32-bit). I haven’t really tested it so let me know if this works. You’ll find the build here: https://dl.dropbox.com/u/139546/OBIA.zip

 

From: Ganesh [mailto:[hidden email]]
Sent: Sunday, March 17, 2013 2:22 PM
To: [hidden email]
Subject: [Opticks-devs] OBIA Plugin Issues

 

Dear Sir,
I have downloaded the OBIA plugin and installed in my Opticks as installe(4.9.1).After executing the Image Segmentation I am getting errors like
MeanShift.exe has stopped working  a problem caused the progarmmee to work properly.CBIA plaun is woring fine new code with
with regards
Ganesh
9650807966




Ganesh Khadanga, Technical Director
LRISD NIC HQRS, A-BLOCK
5th Floor, CGO COMPLEX, LODI ROAD
New Delhi-110003
email: [hidden email]

This message and any enclosures are intended only for the addressee.  Please 
 
notify the sender by email if you are not the intended recipient.  If you are 
 
not the intended recipient, you may not use, copy, disclose, or distribute this 
 
message or its contents or enclosures to any other person and any such actions 
 
may be unlawful.  Ball reserves the right to monitor and review all messages 
 
and enclosures sent to or from this email address.


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs




--

Mohit Kumar

+91-970-3840-175

Lab For Spatial Informatics
International Institute of Information Technology
Hyderabad, India

This message and any enclosures are intended only for the addressee.  Please 

notify the sender by email if you are not the intended recipient.  If you are 

not the intended recipient, you may not use, copy, disclose, or distribute this 

message or its contents or enclosures to any other person and any such actions 

may be unlawful.  Ball reserves the right to monitor and review all messages 

and enclosures sent to or from this email address.

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs




--
Mohit Kumar
+91-970-3840-175
Lab For Spatial Informatics
International Institute of Information Technology
Hyderabad, India

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Opticks-devs mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/opticks-devs
Reply | Threaded
Open this post in threaded view
|

Re: OBIA Plugin Issues

mrwofra
This post has NOT been accepted by the mailing list yet.
In reply to this post by ganesh@nic.in
Hi,
I've found a solution to this problem. I had the same story. First of all you need to install version 4.9.0 Opticks as the OBIA plugin only seems to be working with that release.
Then, when you have downloaded the OBIA plugin to your local drive and unzip it, all you need to do is change the folder name from "Opticks_GSOC2012-master.zip" to "Opticks_GSOC2012.zip". The "master" part seems to be causing the problem.
Please see the "workflow of the plugin" - third slide will have the correct name of the folder: http://opticks.org/confluence/display/~mohitkharb/Workflow+of+the+pluggin

Any questions please let me know.
Regards
wofra