Next version of Opticks will use Qt 4.3.4

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Next version of Opticks will use Qt 4.3.4

Kip Streithorst
Administrator
I have just committed a change to the Trunk that will upgrade Opticks
from Qt 4.3.1 to Qt 4.3.4.  This means the next released version of
Opticks will be using Qt 4.3.4.  This change is both backward and
forward binary compatible with existing plug-ins that were compiled
against Opticks 4.1.0.  

If you are building the Trunk, you will need to upgrade your Opticks
dependencies.  Please follow the procedure listed below (the procedure
is the same for Windows and Solaris):

1) You should have an environment variable OPTICKSDEPENDENCIES already
defined on your system, go to that folder and delete the Qt directory
that you find.

2) Run "svn update" on your OPTICKSDEPENDENCIES folder to get the latest
copy of the Dependencies which includes Qt 4.3.4.  NOTE:  This implies
that your OPTICKSDEPENDENCIES if a subversion checkout of
https://opticks.ballforge.net/svn/opticks/trunk/current/Dependencies.
If not, please make it that way.

3) Acquire Qt 4.3.4.  If you are going to be building open-source
plug-ins or writing code that can be licensed under the GPL or LGPL you
can use our pre-built binary of the open-source edition of Qt 4.3.4.  If
you are writing code under any other license, you must use the
commercial edition of Qt 4.3.4.  For the precise license details, please
consult: http://trolltech.com/developer/downloads/qt/faq

        3.1) If you can use the open-source edition of Qt 4.3.4, please
download our pre-built binary available on the opticks.ballforge.net
website at the following address:

https://opticks.ballforge.net/files/documents/8/112/Qt-4.3.4-opensource.
zip

                3.1.1) Please rename this download to qt-4.3.4.zip and
put it into the OPTICKSDEPENDENCIES\packages folder.

        3.2) If you need to use the commercial edition of Qt 4.3.4, you
will need to buy a commercial license and the follow the Qt build
instructions as defined in

https://opticks.ballforge.net/source/browse/opticks/trunk/current/Code/R
EADME.solaris?view=markup

https://opticks.ballforge.net/source/browse/opticks/trunk/current/Code/R
EADME.windows?view=markup

                3.2.1) Take the resulting .zip that you have created and
rename it to qt-4.3.4.zip and put it into the
OPTICKSDEPENDENCIES\packages folder.

4) Run "python dependencies.py" to install your Qt 4.3.4 into the proper
location.  You are now done upgrading your Opticks dependencies to use
Qt 4.3.4

Thanks,
Kip
       



This message and any enclosures are intended only for the addressee.  Please  
notify the sender by email if you are not the intended recipient.  If you are  
not the intended recipient, you may not use, copy, disclose, or distribute this  
message or its contents or enclosures to any other person and any such actions  
may be unlawful.  Ball reserves the right to monitor and review all messages  
and enclosures sent to or from this email address.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]